Results 1 to 8 of 8
  1. #1
    Junior Member
    Join Date
    Feb 2005
    Location
    UK
    Posts
    1

    Problems with frother on Saeco Royal Professional

    I have one of these machines, but it's developed an aversion to frothing. Press the Capuccino button, it goes through the motions and starts to send steam through the frother attachment. Half the time no milk is drawn up - indeed bubbles appear in the milk jug suggestion steam is being blown down the tube. The rest of the time, milk is drawn up the tube (fairly slowly), but it never gets into the frother - it just sits in the tube. I have cleaned everything several times. There is no sign of any split in the tube, nor the frother and all the seals in the frother seam to be intact. I have tried the froth control needle in all positions. There seems to be a very good of steam. What is happening and why isn't it frothing ? All ideas grateful received.

  2. #2
    Junior Member
    Join Date
    Mar 2005
    Posts
    1

    Frother issues

    I have 2 Saeco and have had these issues on both machines. What happens is the rubber O rings go bad (in my case around 4-6 months)and need to be replaced. I learned how to repair it my self but wouldnt advise you to do it. Did you notice water dripping outside the machine? The O rings for the espresso seem to last much longer.

  3. #3
    Junior Member
    Join Date
    Mar 2005
    Posts
    1
    I have the same problem with my Saeco, opened up the frother and the rubber ring (there's only one) looks ok. What is a sign of ring needing to be replaced?

  4. #4
    Senior Member
    Join Date
    Aug 2004
    Location
    Des Moines, Iowa
    Posts
    1,551
    Poke that gasket with a pick. If the gasket feels hard or breaks apart, you will need to replace it.
    Have you ever walked through the aisle of your local grocer and smelled the death of a dying bean?

  5. #5
    Junior Member
    Join Date
    May 2005
    Posts
    1
    Rallyman, We have had this same problem. We bought new O-Rings etc...it did not help at all. Our previous rings were fine.

    We have solved the problem with the machine not being able to draw the milk up the tube.

    The problem, is the tiny hole in the frother, if you pull the frother off the coffee unit and look down the end. Trust me...it may look alright and it may look like a clear hole but even the slightest calcification / milk deposits WILL stop it functioning properly.

    Get a paper clip (some have dimpled surfaces...these are the best) and push it through the tine hole and try and scrape the sides.

    We have never looked back since. Hope this helps.

  6. #6
    Junior Member
    Join Date
    Oct 2014
    Posts
    3

    YES! You were right!!!

    Just bought a used Royal Pro... only had 230 cups on it so I had a feeling it was going to be a good one. The Frother sidecar didn't froth as it was supposed to... I did what was recommended above and PERFECTO. Pull off the white unit, push a paperclip through and replace.


    Quote Originally Posted by Hoppielimp View Post
    Rallyman, We have had this same problem. We bought new O-Rings etc...it did not help at all. Our previous rings were fine.

    We have solved the problem with the machine not being able to draw the milk up the tube.

    The problem, is the tiny hole in the frother, if you pull the frother off the coffee unit and look down the end. Trust me...it may look alright and it may look like a clear hole but even the slightest calcification / milk deposits WILL stop it functioning properly.

    Get a paper clip (some have dimpled surfaces...these are the best) and push it through the tine hole and try and scrape the sides.

    We have never looked back since. Hope this helps.

  7. #7
    Junior Member
    Join Date
    May 2016
    Posts
    1
    Quote Originally Posted by SFhenry View Post
    Just bought a used Royal Pro... only had 230 cups on it so I had a feeling it was going to be a good one. The Frother sidecar didn't froth as it was supposed to... I did what was recommended above and PERFECTO. Pull off the white unit, push a paperclip through and replace.
    Thank you, thank you!!!

    I stuck a paperclip through the steam wand and it was like a miracle. I joined just to say thanks!!! Such a simple fix!!

  8. #8
    Junior Member
    Join Date
    Jul 2017
    Posts
    1
    Quote Originally Posted by Hoppielimp View Post
    Rallyman, We have had this same problem. We bought new O-Rings etc...it did not help at all. Our previous rings were fine.

    We have solved the problem with the machine not being able to draw the milk up the tube.

    The problem, is the tiny hole in the frother, if you pull the frother off the coffee unit and look down the end. Trust me...it may look alright and it may look like a clear hole but even the slightest calcification / milk deposits WILL stop it functioning properly.

    Get a paper clip (some have dimpled surfaces...these are the best) and push it through the tine hole and try and scrape the sides.

    We have never looked back since. Hope this helps.
    Thanks Hoppie - been having problems with the Cappuccinatore in my Saeco Royal Capuccino - even took the whole thing apart and that didn't solve it.

    Cleaned the Cappuccinatore and even soaked it - but still no good.

    Pushed a paperclip through based on your advice and 100% as new !!!!

    Thought the hole looked clear but obviously even a little bit of gunk stops it working

    A big thanks !!!

 

 

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Saeco Royal Professional Tips and tricks?
    By insanelv in forum Coffee and Espresso Machines
    Replies: 4
    Last Post: 09-10-2006, 05:59 PM
  2. Ventilation problem with Royal Saeco Royal Cappucino
    By hjfritz in forum Coffee and Espresso Machines
    Replies: 0
    Last Post: 06-11-2006, 08:26 AM
  3. Problem with a Saeco Royal Exclusive
    By maximo in forum Coffee and Espresso Machines
    Replies: 2
    Last Post: 05-08-2006, 09:45 AM
  4. krups CAFE DUOMO - frother problems
    By thezig in forum Coffee and Espresso Machines
    Replies: 0
    Last Post: 09-29-2005, 09:19 PM
  5. Saeco Royal Digital Plus?
    By phxflyboy in forum Coffee and Espresso Machines
    Replies: 2
    Last Post: 09-18-2005, 08:55 PM

Search tags for this page

probleming solving saeco coffee machine

,

saeco coffee machine milk not working

,

saeco milk frother not working

,
saeco milk frother problems
,

saeco royal cappuccino milk frother not working

,

saeco royal cappuccino no steam

,
saeco royal cappuccino steam not working
,
saeco royal professional no steam
,

saeco royal steam problem

,
saeco royal troubleshooting
Click on a term to search for related topics.