Results 1 to 1 of 1
  1. #1
    Junior Member
    Join Date
    Apr 2018
    Posts
    1

    Help Please: Delonghi ESAM3500 "Insert Brewing Unit" error

    Hi all - I have an ESAM3500 which has been going strong for probably 10 years and 15000 cups. We had one issue in the past where the frother stopped frothing, solution was to replace the venturi fixture where the milk jug attaches.

    Just the other day, I started getting a "insert brewing unit" message (of course the brewing unit is in the right place). The machine turns on, warms up, runs the usual cycle where it moves the brewing unit through its full range of motion, but instead of rinsing and going "ready", it doesn't rinse, and at the end of the startup cycle it gives the "insert brewing unit" message. If you open and close the door, it "tries again" and repeats the whole cycle.

    After doing a lot of reading I theorized that maybe the upper limit switch wasn't working, but when I put it into test mode and run the brewing unit all the way up, I get a message about upper limit, and same with the lower limit. I've also confirmed that the upper limit switch is working via multimeter (it reads 5V when closed, I assume that's right). I haven't found the lower switch yet but I assume it's also fine.

    Upon very close inspection I see that the "slide" (where the brewing unit attaches) is cracked from the mounting screws down to the bottom. Lacking any better leads, I went ahead and ordered a new slide as well as o-rings (only two though, I didn't realize until today there's a third!), but I'm not really confident this is my issue.

    So while I wait patiently for my parts... any troubleshooting tips? What else could the computer be expecting and failing to see which would make it think there's no brewing unit?

    Thanks!

 

 

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Help Please: WMF Presto Error 5 / Error 2
    By Affogato in forum Coffee and Espresso Machines
    Replies: 0
    Last Post: 03-05-2018, 06:19 AM
  2. Mobile Unit Hot Water
    By VillageCoffee in forum Coffee Shops, Espresso Bars & Cafes
    Replies: 1
    Last Post: 01-22-2015, 04:48 PM
  3. Saeco Idea Brewing Unit Error .... Help please!
    By tink in forum Coffee and Espresso Machines
    Replies: 10
    Last Post: 05-17-2013, 08:12 AM
  4. Is this a good starter unit?
    By LGHT in forum Coffee and Espresso Machines
    Replies: 13
    Last Post: 04-25-2011, 03:11 PM
  5. Saeco Incanto Sirius Setup Error Message \"Brew Unit Bl
    By digibabe in forum Coffee and Espresso Machines
    Replies: 0
    Last Post: 01-15-2007, 10:28 AM