Results 1 to 8 of 8
  1. #1
    Junior Member
    Join Date
    Mar 2004
    Posts
    1

    Francis X1 problem

    Hello!

    Unfortunately, I am having problems with my Francix X1.

    Everything worked fine until I steamed milk the last time. Since then, I can not make coffe any more. Steaming still works fine. Whenever I turn the machine on, the left lower light is on - i think that before it was on only after I turned on the right switch. The temp also goes above 100° always. The right switch does not change anything. Steaming still works. When trying to make coffee, the pump still works but it sounds like it has to work against resistance or like s.th. blocked?!

    Any help is greatly appreciated!!

    Thank you,
    Sven

  2. #2
    Junior Member
    Join Date
    Jan 2004
    Location
    Redmond, WA
    Posts
    14
    Hi Sven,

    I'm not a technician and I'm not sure why the pump has to push so hard to get water out of the boiler. But I've had to have the heating element replaced in my machine because I let the boiler run dry while it was on steaming temperature. The lower light was flickering, even when the main power switch was turned off. It seemed like a goofed up electrical problem.

    You should probably call a FrancisFrancis tech for suggestions or setup to have your machine serviced. Toll Free (877) 854-4141.

    By they way, if anyone reads this, get updated documentation for your X1 machine because it gives some extra instructions on care. My mistake was to steam a milk and let the boiler run dry -- it burned the element in the boiler. I didn't set the switch to coffee brew temp and fill the boiler again after steaming milk.

    Gary

  3. #3
    Junior Member
    Join Date
    May 2004
    Location
    USA
    Posts
    5
    I was going to purchase a Francis until I did some research on the internet and found out they have one problem after another. See if you can get a refund and purchase a Simona "Top" You can't go wrong.

  4. #4
    Junior Member
    Join Date
    Aug 2004
    Posts
    6
    Hi Sven,
    I'm now facing exactly the same problem as you. Please help. How you deal with it? I called francis and they said I need to send mine to their IL repair shop and the cost will be anywhere from $75 to $200.

    Singh

  5. #5
    Junior Member
    Join Date
    Aug 2004
    Posts
    6
    I replaced the pump which i ordered it online $50. Now my baby is just working like new.

  6. #6
    Junior Member
    Join Date
    Sep 2004
    Posts
    3
    Quote Originally Posted by tohff
    I replaced the pump which i ordered it online $50. Now my baby is just working like new.
    How did you do that? and where did you get the new pump?

  7. #7
    Junior Member
    Join Date
    Aug 2004
    Posts
    6
    When you open the top of your francis, you'll find insides are basically connected.
    I order the replacement from
    http://www.1st-line.net/cgi-bin/categor ... type=store

    choose the plastic output and you'll get a 52watt version just like the one originally installed in your ff.

  8. #8
    Junior Member
    Join Date
    Oct 2006
    Location
    Northamptonshire, England
    Posts
    1

    Re: Francis X1 problem

    Hello Sven. This post is very old but my answer might help other forum members to identify the problem here. It`s quite simple to ask "what happens when I froth the milk". The simple answer is that the boiler thermostat is bypassed probably with a relay of some description and this relay sticks in the on position until it is reset somehow. Exactly the same thing happened to my X1. One day I used the milk frother and soon after it would boil the water until steam was coming from everywhere. I believe that this is a commen problem. The left lower light indicates that the boiler is on and should in normal use flicker to indicate that the operating temperature has been reached
    Quote Originally Posted by sven
    Hello!

    Unfortunately, I am having problems with my Francix X1.

    Everything worked fine until I steamed milk the last time. Since then, I can not make coffe any more. Steaming still works fine. Whenever I turn the machine on, the left lower light is on - i think that before it was on only after I turned on the right switch. The temp also goes above 100° always. The right switch does not change anything. Steaming still works. When trying to make coffee, the pump still works but it sounds like it has to work against resistance or like s.th. blocked?!

    Any help is greatly appreciated!!

    Thank you,
    Sven

 

 

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Illy Francis!Francis! X5 membership program...problem
    By CiaoNY in forum Coffee and Espresso Machines
    Replies: 2
    Last Post: 03-24-2007, 02:31 PM
  2. Francis Francis X5 for sale with free case of Illy Caffe POD
    By CJ2Stay in forum Coffee and Espresso Machines
    Replies: 0
    Last Post: 05-18-2006, 12:15 PM
  3. My Francis Francis Drama. Anyone in Atlanta GA that can fix?
    By raind00gg in forum Coffee and Espresso Machines
    Replies: 1
    Last Post: 12-14-2004, 11:57 PM
  4. Francis Francis X1 tripping GFI - can't use it
    By A2tracy in forum Coffee and Espresso Machines
    Replies: 3
    Last Post: 09-30-2004, 08:58 PM
  5. francis francis repairs
    By alicef in forum Coffee and Espresso Machines
    Replies: 7
    Last Post: 12-20-2003, 06:10 PM

Search tags for this page

francis francis heating element
,
francis francis steamer not working
,

francis francis troubleshooting

,

francis francis x1 heating element

,

francis francis x1 not working

,

francis francis x1 problems

,
francis francis x1 pump replacement
,
francis francis x1 steam problem
,
francis francis x1 steamer not working
,

francis francis x1 troubleshooting

Click on a term to search for related topics.