Results 1 to 7 of 7
  1. #1
    Junior Member
    Join Date
    May 2012
    Posts
    1

    Help Please: At wits' end DeLonghi Magnifica steam function

    Hello all,

    I'd be very grateful if anyone could provide some insight regarding the problem I'm having with my new espresso machine.

    I've had a DeLonghi fully automatic espresso machine for about 3 months now and I'm nearly ready to send it to the recycling depot. While I quite like the coffee it produces, the steam function seems to be deteriorating and is currently almost useless. Essentially, it starts out strong but peters out after about 1.5 minutes such that it's sputtering water with bursts of steam and it starts to make an awful screaming noise. By about 3 minutes it just sputters water with short, gently puffs of steam occasionally. Currently, it is all the machine can do to steam about 1 cup of milk for my morning latte.

    Now the manual does mention that a "safety device stops steam delivery after 3 minutes" which from what I can tell is intended to prevent you from over-steaming your milk. Super. It goes on to say that you should "Wait, then activate the steam function again." Unfortunately, I seem to need to wait for at least an hour to be able to steam another cup of milk - I assume until everything has cooled back down to room temperature. This seems like a safety feature got wrong.

    It was a little better initially, when I first got it. I recall being able to make 3 lattes in close succession (although with a lot of screeching). Now, however, this is impossible. One per hour seems to be the limit.

    I've spoken to DeLonghi support and they directed me to a service technician (the only one in Calgary, apparently) but after having it for two weeks his contribution was to tell me that it was functioning to specification and that all the new machines worked this way. His interest in my problem was low.

    It did seem to behave a bit better when I brought it home from the service depot but over the last month it seems to slowly be getting worse such that this morning, my milk barely made it to 140 degree F and I thought I might rupture an eardrum getting it there.

    I've descaled the machine 3 times since I've had it with the magic DeLonghi descaling solution, so I'm certain this is not an issue. The steam wand is clean as a whistle as well.

    My previous espresso machine was a Saeco Vienna which essentially provided limitless steam so I'm really finding this "upgrade" difficult to deal with.

    My questions:
    - Is this just the way these DeLonghi's are?
    - Does anyone have one of these that does function reasonably?
    - Is there any way to influence this safety "feature"?

    Any help or insight would be much appreciated.

    Thank you in advance,
    Brent

  2. #2
    Senior Member
    Join Date
    Aug 2005
    Location
    Central North Carolina
    Posts
    1,541
    I know little about super-autos, but it sounds like the problem you're having is just the nature of the beast. Those machines use thermoblocks to flash heat the water as it passes through and the problem with most of them is consistency, either with brew temperature or steam production.

    The 3 minute "safety device" is probably utilized because that may be the realistic limit of many thermoblocks. I'd have to believe the typical thermoblock would be useless at or beyond that point.
    I'm a legend among my own kind... you my friend are just a legend in your own mind. Later!

  3. #3
    Junior Member
    Join Date
    Oct 2014
    Posts
    1
    Hello,

    I've joined the forum in the main to respond to this rather old thread as I had exactly the same problem with the same type of machine - or at least I thought I did. Your description of the problem is identical to what I was experiencing and after reading your post I was convinced my machine had a fault. However, a few days ago I was using the machine and stumbled upon what was wrong. In my case it was user error and although I'm not suggesting you made the same mistake, it's certainly worth considering and might prove useful to other readers. What I overlooked was rather simple: after making a coffee I would immediately use the steam function to heat the milk by turning the steam dial by 180 degrees. Crucially, what I didn't do first was press the steam button and wait until it stopped flashing and went on steadily. During this time the machine can be heard moving parts internally. This has made all the difference. The steam function is now going like the clappers but before it spluttered away in exactly the manner you describe. A silly mistake, but quite easily overlooked as the button and dial are two separate bits of the machine.

    As it happens, I got my machine at a recycling depot shop for a tenth of the RRP. Did you ever take yours there? Maybe I bought it

  4. #4
    Super Moderator
    Join Date
    Feb 2008
    Location
    Near Philadelphia, PA
    Posts
    5,003
    Hello "rogerbucklesby"

    Welcome to the Coffee Forums.

    We don't mind when a person responds to an old thread, especially when the response is informative and helpful.

    It's great that you were able to figure out what was causing the problem. Thanks for sharing your experience with us.

    Rose

  5. #5
    Junior Member
    Join Date
    Jan 2016
    Posts
    1
    thankyou roger!!!!and thank you coffee forum for posting a older post .I was having the exact problem with my frother ...basically just got warm milk. I tried your fix and am currently enjoying a wonderful cappauccino with killer froth thank you roger for being thoughtful enough to respond to a user problem

  6. #6
    JJP
    JJP is offline
    Junior Member
    Join Date
    May 2020
    Posts
    2
    Quote Originally Posted by rogerbucklesby View Post
    Hello,

    I've joined the forum in the main to respond to this rather old thread as I had exactly the same problem with the same type of machine - or at least I thought I did. Your description of the problem is identical to what I was experiencing and after reading your post I was convinced my machine had a fault. However, a few days ago I was using the machine and stumbled upon what was wrong. In my case it was user error and although I'm not suggesting you made the same mistake, it's certainly worth considering and might prove useful to other readers. What I overlooked was rather simple: after making a coffee I would immediately use the steam function to heat the milk by turning the steam dial by 180 degrees. Crucially, what I didn't do first was press the steam button and wait until it stopped flashing and went on steadily. During this time the machine can be heard moving parts internally. This has made all the difference. The steam function is now going like the clappers but before it spluttered away in exactly the manner you describe. A silly mistake, but quite easily overlooked as the button and dial are two separate bits of the machine.

    As it happens, I got my machine at a recycling depot shop for a tenth of the RRP. Did you ever take yours there? Maybe I bought it
    Hello, I have a DeLonghi Magnifica and today after a year of use, it started to not make froth and got a lot of bubbling when trying to froth. On a DeLonghi, the steam knob that you turn 180 degrees does not stop flashing during frothing period? Are you saying you drop the espresso first and then froth? Not sure what that does by dropping the espresso shots first and then trying to froth?

  7. #7
    JJP
    JJP is offline
    Junior Member
    Join Date
    May 2020
    Posts
    2
    I am not sure if using this thread properly but I have a DeLonghi Magnifica and today after a year of use, it started to not make froth and got a lot of bubbling when trying to froth. On a DeLonghi, the steam knob that you turn 180 degrees does not stop flashing during frothing period? Are you saying you drop the espresso first and then froth? Not sure what that does by dropping the espresso shots first and then trying to froth?

 

 

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Delonghi Magnifica slow switch from steam to coffee
    By Vodkaneat in forum Coffee and Espresso Machines
    Replies: 1
    Last Post: 05-07-2020, 06:13 AM
  2. Help Please: Delonghi magnifica esam30xy not working.
    By Seedycad in forum Coffee and Espresso Machines
    Replies: 1
    Last Post: 03-06-2018, 01:29 AM
  3. Help Please: Delonghi Magnifica 3500SM
    By Lisa77 in forum Coffee and Espresso Machines
    Replies: 0
    Last Post: 09-19-2017, 07:59 PM
  4. DeLonghi Magnifica - Questions
    By Ogre in forum Coffee and Espresso Machines
    Replies: 4
    Last Post: 12-31-2007, 01:32 PM
  5. delonghi magnifica
    By tenmiler in forum Coffee and Espresso Machines
    Replies: 0
    Last Post: 05-04-2005, 10:11 AM

Search tags for this page

delonghi coffee machine not frothing milk
,
delonghi deminica too much water in tray
,
delonghi magnifica faults
,
delonghi magnifica not making steam
,
delonghi magnifica not steaming
,
delonghi magnifica problem solving
,

delonghi magnifica problems

,
delonghi magnifica troubleshooting
,
delonghi steam problem
,
does anyone have one of the older cappaccino michines ,just heats and a botton to make it foam
Click on a term to search for related topics.