Results 1 to 1 of 1
  1. #1
    Member
    Join Date
    Oct 2011
    Posts
    49

    Low h20 temp @ grouphead

    I have a 2 group C.M.A. SME2N aka Rio aka Astoria. I have noticed the boiler pressure level drops significantly every time I open the steam wand. It holds pressure just fine pulling shots. I then checked the water temp coming from the grouphead by sticking the frothing thermometer into the shotglass as the grouphead dispensed water. It held at a steady 160 Deg F. the hot water dispenser was around 190 F or so. I started investigating further and noticed the main relief valve has a slow steady leak. One last bit of info is the red power indicator light is constantly dimming/flickering. I don't know if any of these things are related.
    Thanks for any feed back.
    Jim.

 

 

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Astoria Gloria SAE 3 grouphead water flow
    By Colossal511 in forum Technical Support
    Replies: 0
    Last Post: 02-12-2013, 11:33 PM
  2. ambient temp and bean temp
    By Jazz in forum Coffee Roasters
    Replies: 31
    Last Post: 10-09-2012, 11:26 PM
  3. Silvia PID temp set?
    By kimwroble in forum Coffee and Espresso Machines
    Replies: 4
    Last Post: 01-18-2009, 01:21 PM
  4. temp, color and oil?
    By lizzy in forum Coffee Roasters
    Replies: 3
    Last Post: 03-28-2006, 11:01 AM
  5. grouphead
    By luvmyespresso in forum Coffee and Espresso Machines
    Replies: 3
    Last Post: 05-29-2005, 11:21 PM