Results 1 to 8 of 8
  1. #1
    Junior Member
    Join Date
    Nov 2019
    Posts
    7

    Question Saeco Exprelia Evo will not grind coffee E01 - chute is CLEAN!!

    Hello,

    I have a Saeco Exprelia Evo and it thinks the coffee chute for the grounds to the brew group is blocked. It can't be. I've cleaned it 300 times... I used my super powerful central vacuum on it exactly the way the trouble shooting recommends... I've tried a pipe cleaner.

    Does anyone have any ideas why this might be giving me the error that there is an obstruction? Maybe some others have had this issue as well. Maybe there is a way to take it apart ??

    Thank You for your help !

  2. #2
    Super Moderator
    Join Date
    Feb 2008
    Location
    Near Philadelphia, PA
    Posts
    4,797
    If you want to try to take it apart to look inside, here are some diagrams that may help you figure out how to put it back together.

    https://www.google.com/search?q=saec...=1572797595179

  3. #3
    Senior Member
    Join Date
    May 2014
    Location
    Kansas City
    Posts
    1,108
    I assume you have tried this: https://youtu.be/dO-esf5dhnY

  4. #4
    Junior Member
    Join Date
    Nov 2019
    Posts
    7
    Thank you all for the replies. I did do that clean out with the spoon. and I also used a vacuum like the instructions say.

    I opened the machine up yesterday and took out the grinder. Here are some pictures.

    https://imgur.com/gallery/H4QwZ3m

    You can see the chute with that metal thing on it. It's a flap that moves back and fourth, im assuming to keep anything or steam from traveling up into the grinder? Does anyone know what it's proper position should be? is it the sensor?? It can sometimes get stuck backwards so I'm not sure which way it should go. Its also a little bent in one corner.

    The other pics show the grinder where I did find some buildup on the edge of the ceramic. I scraped it away, and rotated the grinder to reveal the next window and again scraped it away until the entire ceramic piece was cleaned up.

    Put it all back together and STILL have this problem. :/ Here is a video of the issue and diagnostics screen of the grinder.

    https://imgur.com/gallery/S42ihWE

    Does anyone know this machine?? THANK YOU !!!!

  5. #5
    Senior Member
    Join Date
    May 2014
    Location
    Kansas City
    Posts
    1,108
    I think I would call Phillips about that bent sensor... I would bet that is your issue.

  6. #6
    Junior Member
    Join Date
    Nov 2019
    Posts
    7
    Quote Originally Posted by Musicphan View Post
    I think I would call Phillips about that bent sensor... I would bet that is your issue.

    Thanks.. good idea. Hopefully I can order a new one. I bought a replacement door hinge before. It's just really weird for that to be the sensor... I couldn't see any electrical connections being made to it at all. I'll try reaching out to Philips

  7. #7
    Senior Member
    Join Date
    May 2014
    Location
    Kansas City
    Posts
    1,108
    Quote Originally Posted by inck243 View Post
    Thanks.. good idea. Hopefully I can order a new one. I bought a replacement door hinge before. It's just really weird for that to be the sensor... I couldn't see any electrical connections being made to it at all. I'll try reaching out to Philips
    That is odd... I would have thought there is a connector as well. Time to call Phillips... report back!

  8. #8
    Junior Member
    Join Date
    Nov 2019
    Posts
    11
    Quote Originally Posted by Musicphan View Post
    I think I would call Phillips about that bent sensor... I would bet that is your issue.
    +1

 

 

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Saeco Magic Deluxe won't grind coffee
    By mhumphri in forum Coffee Shops, Espresso Bars & Cafes
    Replies: 2
    Last Post: 08-24-2018, 03:43 PM
  2. Replies: 2
    Last Post: 04-18-2018, 08:48 PM
  3. Advise Needed: Grind Setting for Cuisinart Supreme Grind™ Automatic Burr Mill
    By nakedland in forum Coffee and Espresso Machines
    Replies: 16
    Last Post: 12-30-2015, 10:49 PM
  4. What is the best auto-clean/burr grind/brew for the money?
    By ken in forum Coffee and Espresso Machines
    Replies: 1
    Last Post: 12-14-2004, 02:54 PM

Tags for this Thread