Ambex YM-5 burners not staying lit...

elguapo

New member
May 1, 2011
38
0
Hi,

We're having an issue with our Ambex YM-5 where about 3-4 pairs of jets (natural gas) go out mid roast and will not go back on. We can get a couple going again if we turn the airflow down all the way, and they will stay lit for a few minutes, but then they want to go our again. We have tried cleaning with compressed air, but it didn't seem to help much.

The machine is about 4 years old, do the burners have to be replaced at some point? Should we pull out the burner assembly and all the jets off to clean them? Any suggestions would be appreciated.

Thanks!
 

sae

Member
Nov 16, 2010
183
0
when they are running is the flame bouncing off the burning (like it's dancing in space?)

Maybe post a photo of the burner running just before it goes out so we can see what the flame looks like
 
OP
E

elguapo

New member
May 1, 2011
38
0
  • Thread Starter
  • Thread starter
  • #3
when they are running is the flame bouncing off the burning (like it's dancing in space?)

Maybe post a photo of the burner running just before it goes out so we can see what the flame looks like

It definitely bounces off the burner when the gas is set at about 50% or above, regardless of airflow.

In the first photo (which might be upside down), the gas is set to 60%, only one row is lit and on the lit row, you can see the flame dancing off one of the jets.

IMG_8721.JPG

Second photo is how it looks on 10% gas, all lit in row closest to me, but back row remains off.

IMG_8723.JPG

Both pics taken with airflow at 100%. If I decrease airflow or blow lightly on the burners, I can get most lit...

Thanks!
 
Top