Older espresso machine: need help

vwnobby

New member
Jan 5, 2005
2
0
Hello,
My father has an espresso machine that is probably 14 yrs old and has been acting up lately. He recently took it apart to see if he could fix it. When he removed the boiler (not sure if this is the correct term) he noticed a lot of what he thought was sediment inside. I thought it might be scaling. It resembled very course sand. So he removed it and put the machine back together and now the coffee tastes horrible and has a metalic taste to it. Not to mention that the machine constantly spews water as soon as the water heats up. Anyway, does anyone know if the material we thought was sediment, was some sort of filtering system? I have done many searches online for what I think is the name of the machine and have come up with nothing. Has anyone heard of the following machine:

Euromax new President Espresso

I'm not really sure which is the brand name and which is the model name. I just wrote down what was on the front of the machine. If it helps, it is a comination machine (grinder and espresso machine). Sorry for the long winded post, but I am trying desperately to find any info on this. Any help from anyone would be greatly appreciated.
Thank you.
 

CCafe

New member
Aug 11, 2004
1,557
0
Des Moines, Iowa
I have never worked on one, but it probably was sediment. When you dad tore the machine down to he replace all the gaskets with new ones? Also did he tear apart any type of solenoid valve? I would start looking there for your water leaks. Also take a look at all the connections and make sure nothing else may be leaking.
 
OP
V

vwnobby

New member
Jan 5, 2005
2
0
  • Thread Starter
  • Thread starter
  • #3
When he took it apart, he did not remove the pump or anything resembling a solenoid valve, I think. the only thing he took apart was part that housing that heats the water. The part that leaks is where the filter cup holder latches (where the water is dispensed from). As soon as the machine is powered on, water starts to squirt from there.
 

edna713

New member
Nov 17, 2004
14
0
SC
sediment

yes that was probably old minerals etc. get some Cleancaf form Urnex -- use as directed -- and that may help you! FLUSH THOROUGHLY!! may have to do it twice!

dave
 

Baggs

New member
Jan 14, 2006
1
0
Same machine same problem.

I just got the same machine used of course it is fire engine red and chrome.The tag just says made in Italy and the voltage. Every time I type in the name in a search engin I keep getting German websites.Any way I have not taken it apart yet should I or should I just leave it alone? Where Could I get parts for it if I wanted to.
John
 

andrewmillett

New member
Jan 28, 2006
1
0
euromax president espresso

Hi. I have the above machine that I see that has already been discussed here. It is no longer working correctly. The frother steamer does not work and there is leakage of water from the top of the heater unit where all the electrical connections are. Can this unit be opened up to inspect for damage?
 

DavesLT

New member
Nov 6, 2005
64
0
Missouri
Old Espresso Machines

OK, I've been selling and repairing espresso machines for twenty years, and what I've learned is that some machines are just not worth fixing.

Here's the deal, a lot of the Italian espresso machines sold in the US over the last three decades were made by companies that are either no longer in business, or they are not shipping to America anymore. Some of the parts used on these machines were proprietary, and some were not. In either case, you will spend untold hours looking for parts that match the parts you will need to replace, and some you will never find.

My suggestion is, if you're determined to buy a used espresso machine, make sure that it's one you can redily find parts for... and that sentiment goes for new machines as well.

Good Luck, Dave
 

karlm1234

New member
Oct 19, 2010
1
0
Hi

I inherited a machine like this and took it apart as the Heater was not heating, Cleaned it and found the Sediment like you and then put together but heater still fails. I also short circuited one of my wall plugs as I shorted the ground . Anyway Is there anyone fixng these?

Karl
 
Top