Delonghi eletta cappuccino top, no milk or steam.

Mmctid

New member
May 7, 2024
3
0
Wigan
Visit site
Hello, I'm hoping someone here will be able to help with this problem. My delonghi ecam 45.760w until recently worked great. Then the milk functions stopped working. The machine still beeps when the milk tank is connected but after that the buttons just said heating up and that was it.
I went ahead and replaced the two thermal cutout fuses but nothing changed. After that I swapped out the carafe coupling with still no change.

As it stands at the moment, when the machine is turned on, it goes through it's cycle, self diagnosis, heating up, rinsing, then heating up. At this point it does not change and will if left move in a General Alarm state. If interrupted by pressing the hot water button it asks for the water spout and then clears the heating up message and coffee can be made as normal.

Also, the steam function doesn't seem to do anything other than chug endlessly.

I would love some concrete help as currently I'm just scouring you tube for different videos in the hope that one of them will get me to a fix.
I have two solenoid valves on order which I was going to fit as soon as they arrive.

Thank you for reading this wall of text, Ive tried to be thorough, buuuut, it's a lot.
 
Back
Top