Help Please: Questions about my Breville Barista

mike_b

New member
Mar 2, 2021
2
0
I have had this machine for a couple of years and I am quite happy with it. Today something happened that I don't quite understand:

The machine blinked at me yesterday to clean it. So, I filled the tank and followed the instructions to use one of those Cafica (?) pills to clean the machine. Everything went fine, the "clean me" light was off after the cleaning.

This morning I wanted to make a coffee like I always do: grind the coffee, use the double wall basket, tamp it down, start the process. Right away I noticed that the pressure went up quite a lot on the gauge (almost all the way), but no coffee was coming out. So, I stopped it and tried again. Same result. I figured that perhaps the basket was dirty, so I used the single wall basket. This time coffee was delivered, but the pressure stayed at zero. I then used one of those Cafica pills to soak the double wall basket, and then tried to brew another coffee with it. this time coffee was delivered, but the pressure gauge only went up about a quarter (before the cleaning it would go up about half way).

What does that all mean? Is there something wrong with the machine? Did the high pressure in the beginning break something?

Has anybody seen something similar?
 
OP
M

mike_b

New member
Mar 2, 2021
2
0
  • Thread Starter
  • Thread starter
  • #2
Follow-up to my question.

I have noticed a few more things since I posted the question:

1) The machine seems to make a "harder" noise than before, a more metallic noise.
2) The pressure gauge now tops out at around "9 o'clock". It used to go to about 12 before. Nothing has changed (grind, amount, water).
3) the amount of coffee dispensed is definitely less than before.

Could it be that the overpressure during the first coffee after the cleaning cycle damaged the pump?
 
Top