Keurig K-Elite delay before brewing starts

Apr 29, 2020
98
1
hey guys;
I have a Keurig K-Elite. In the morning I refill the reservoir and power the unit on. Normally, it takes about a minute to bring the water up to temp, and when I start a brew, there is only a slight delay before brewing starts. But recently, it is taking about 30 seconds from the time I hit the brew button to the start of brewing. During the delay, the machine just sits there doing nothing. The brew light (the cup size I have chosen) remains lit.
Could this be a sign that the machine needs descaling? I haven't done it in a while.

Thanks for your help
Ultrarunner
 

PinkRose

Super Moderator
Staff member
Feb 28, 2008
5,218
6
Near Philadelphia, PA
hey guys;
I have a Keurig K-Elite. In the morning I refill the reservoir and power the unit on. Normally, it takes about a minute to bring the water up to temp, and when I start a brew, there is only a slight delay before brewing starts. But recently, it is taking about 30 seconds from the time I hit the brew button to the start of brewing. During the delay, the machine just sits there doing nothing. The brew light (the cup size I have chosen) remains lit.
Could this be a sign that the machine needs descaling? I haven't done it in a while.

Thanks for your help
Ultrarunner

Since you haven't done the descaling in a while, it sounds like it would be a good idea for you to do it now, and see what happens. There is a very good chance that you will see an improvement.
 
OP
U
Apr 29, 2020
98
1
  • Thread Starter
  • Thread starter
  • #3
I will do the descaling, but I also found that if I don't hit the brew button immediately after the water finishes heating, there is no delay between pressing it and start of the brewing process.
 
Top