Saeco Royal Professional - FILL WATERTANK Message Issue

CuiZinieR

New member
Feb 8, 2015
1
0
Hi,

I just wanted to share the issue I encountered with an old Saeco Royal Professional and the fix that worked for me.

Description of the issue:

The screen would show FILL WATERTANK even if there was enough water in the tank. After some search on Internet, it seemed to come from a problem with the sensor located inside the machine.


How does the water level detection work?
(according to my noob understanding)

In the water tank, there's a grey plastic block floating in a chamber sealed by a white plastic cap. Inside the block, there's a magnet. Under the hood, there's a reed switch aligned with the magnet. When the magnet is close to the switch, it means that there's not enough water. When the magnet doesn't trigger the switch, it means there's enough water as it's floating far enough.

Intervention:


Firstly, I took out the black block from the water tank which should not trigger the FILL WATERTANK message but the message still remained.
Secondly, I opened the coffee machine to access the cabling, found the reed switch and tested it with the black block:


  • Switch w/o the block:

Expected result: No FILL WATERTANK message => NOK



  • Switch with normal block position on top of it

Expected result: FILL WATERTANK message => OK



  • Switch with up side down block position on top of it

Expected result: unknown => sometimes it worked, sometimes it didn't



  • Switch with block besides it:

Expected result: unknown => OK

Conclusion:

The switch doesn't have a normal behavior. But seems it works with the last position, I taped the block on the side of the switch and left the bundle on the right side of the machine.
CAUTION: there's no more FILL WATERTANK message even if there's no water so we must be careful about the water when using the machine.


PS: I had many photos and links to illustrate this message but the forum doesn't allow me to post them, so not my fault.

 
Last edited:

Steve.Linda

New member
Mar 27, 2016
2
0
We solved this like the three bears! We have had the fill watertank message on our Saeco (not the professional model). It has the float magnet, similar to other models. We SOLVED the problem by having a pitcher of water (with a top) on the counter. We refill with this and it worked every time. When we use cold tap water, especially in the winter. We also tried warm water and the density of the water is less and makes the magnet float stay at the bottom. The room temperature water was just right (like the three bears). In addition, this worked without going into the machine itself. Hope you can try this first
 

KhunLA

New member
May 15, 2021
1
0
Easy & simply solution - cut the the sensor and connect the 2 wires. I just did it an no fill error. Just keep water reservoir topped up, as no more 'fill' warnins.
 

Latest posts

Top