Help Please: I Need Saeco Exprelia Evo Troubleshooting Advice

pjdb

New member
May 3, 2021
1
0
I have a Saeco Exprelia Evo that I've used without issue for 3+ years, making around 5 espressos daily. Eventually I noticed the rate coffee was being produced had slowly decreased to a point I could no longer tolerate. Periodic maintenance has been done on all typical-user capable parts and descaling treatments completed, etc. When I did the last descaling treatment (thinking this may be the cause) the cycle would never complete, regardless of all the proper resetting ,etc. Afterwards the machine would always be stuck in priming mode and give the 05 error and could never make a batch of coffee. It seemed to me that a flow path must have been plugged or a solenoid was stuck open because during the priming cycle the water would go directly to the drain-tray. I figured out how to dissemble the thing and checked the entire flow path. Nothing was blocked. I finally figured out the main solenoid pump was not producing the proper flow and replaced it. Moreover, I later found that the part of the priming cycle in which the larger solenoid-pump runs, completes fine, it is only once the second, smaller solenoid pump is put into the cycle that the cycle fails. Also, the smaller pump delivers water at the correct rate so I think it must be something downstream of that pump, it's check valve works fine too.

Thinking I solved the problem by replacing the faulty large pump, the following happens during a normal cycle of making an espresso->
Machine powers on and goes in to rinse.
Machine displays <-STOP and is the only way to stop the rinse. It will continuously drain the water reservoir if STOP is not pressed.
If STOP was pressed the machine heats and goes into the ready mode.
Pressing the espresso button starts a normal grind and the machine produces coffee. However, the machine will dispense about 150ml of coffee ( about 2 x what it's set for ), then stop. Then in a few seconds it starts dispensing the same dilute coffee again and will run the reservoir dry, continuously, unless the <- STOP that appeared on the menu screen when the pump came back on that second time, it would never stop. The process bar never changes now either, it's always an empty bar as if flow wasn't being sensed.

Reading other's troubles with these machines I thought that it may be the flowmeter under the reservoir that was the culprit. When I replace that, the machine will again get stuck and quit at precisely the same time in the loop within the prime cycle that it did before I replaced the motor originally!

I have also replaced the 5-solenoid o.mix that dispenses to the foam thing I never use. Same result with and without new flowmeter.

I make coffee now by keeping in the old flowmeter and timing how long it takes to dispense out 70 mls, 5 times! Help! I'm not sure what could be wrong. Is there some other flow/pressure sensor that could be causing this?


thanks,
-Pete

*I have since located a service manual. The problem seems to be related to the flowmeter. In TEST MODE there are steps in which individual flow paths may be pressurized by either the large or small impulse pumps. Apparently each pump is in working order if there are 10 and 5 pulses/produced while running the large and small solenoid pumps, respectively, through the main coffee-dispensing solenoid valve. The flow is measured via the flowmeter and reported in one of the test screens. The reported flow from the TEST MODE was 0-1 pulse/s from each pump, regardless if I used a newly purchased flowmeter or the old one. I know this is not correct, they both produce the correct volume of water when the solenoid is removed and the solenoid functions fine. I'm thinking neither is bad. How likely would it be for the new one to be bad too? It's just a simple magnetic flowmeter. Both spin perfectly. Now I'm totally clueless of how to proceed.
 
Last edited:

EmmaScoth555

New member
May 9, 2021
9
0
ND
Thanks for sharing your advice! I will put into practice your instructions ... Nice to see intelligent interlocutors!
 

Latest posts

Top