Problem with a Saeco Royal Exclusive

maximo

New member
Mar 6, 2006
3
0
Hi.

I have a Saeco Royal Exclusive which worked very well until now brewing a delicious coffee . I always used filtered water, did the discaling & cleaning maintenance. 23 months later the machin stopped working

The problem is when pressing for any of the 3 possible coffee sizes, the beans are grinded, the pump start sending water and it even sounds and smell like it is being brewed but instead being poured in my mug the coffee is poured mostly inside the Dreg Drawer.

It looks like the water is not going all the way through the normal piping/circuit.

Does someone has an advice or tip on the fix needed ?

Does someone know a repair/service place around houston/texas where I can send my machin. The only repair service backed by Saeco is located in Dallas and the record at the Best Busines Bureau is not very optimistic.

The closest other Saeco service besides Dallas is located in Phoenix, AZ, so if I have to send the machin that far I would prefere to do it for a place with references or reviews.

Thanks for any help, clue, or tip about this issue

Regards
 

Parts Guru

New member
Jan 1, 2005
34
0
Lansale, PA
Hi.

I have a Saeco Royal Exclusive which worked very well until now brewing a delicious coffee . I always used filtered water, did the discaling & cleaning maintenance. 23 months later the machin stopped working

The problem is when pressing for any of the 3 possible coffee sizes, the beans are grinded, the pump start sending water and it even sounds and smell like it is being brewed but instead being poured in my mug the coffee is poured mostly inside the Dreg Drawer.

It looks like the water is not going all the way through the normal piping/circuit.

Does someone has an advice or tip on the fix needed ?

Does someone know a repair/service place around houston/texas where I can send my machin. The only repair service backed by Saeco is located in Dallas and the record at the Best Busines Bureau is not very optimistic.

The closest other Saeco service besides Dallas is located in Phoenix, AZ, so if I have to send the machin that far I would prefere to do it for a place with references or reviews.

Thanks for any help, clue, or tip about this issue

Regards

There is nothing seriously wrong with the machine.You have not looked closely at the brew group. It has any of the following problems for the condition you describe:

1- The O-ring on the plastic screw that holds the filtyer screen is worn out. I am sure that has not bee replaced.
2- The screw was tightened with the key that comes with the machine. Tightening too hard can loosen or remove the threaded brass piece inside the screw. As a result, the filter screen remains loose and allow water to remian behind and add it into the dredge drawer.
3- The piston block can be cracked and allow water to leak.
4- The brew valve seated under the espresso outlet on top of the brew group has a bad o-ring. That will allow water to leak and accumulate is the well where the plastic screw is lodge to hold the filtyer screen.

Please use the link below to find exploded diagram of the brew group and maintenance/cleaning instructions.
http://www.partsguru.com/SaecoBrewGroup.html.

You do not have to send the machine to no body. Fix it yourself.
Good luck
 
OP
M

maximo

New member
Mar 6, 2006
3
0
  • Thread Starter
  • Thread starter
  • #3
Thanks

Thanks For the information. I will give it a shot and if it gets too tricky I will just acquire a new brew group. Anyway it looks like there is no need in shipping my machine.

Again thanks for your time and the information.
 
Top